Back to overview
Resolved

Release 0.62.0

May 12, 2026 at 12:00pm UTC  –  May 12, 2026 at 12:08pm UTC
Affected services
app.mago.studio/api

Resolved
May 12, 2026 at 12:08pm UTC

Release successful

Updated
May 12, 2026 at 12:08pm UTC

Maintenance ended

Created
May 12, 2026 at 12:00pm UTC

Backend API would be temporarily unavailable, which will render the app unusable for a short period.